import re
regex = re.compile(r"(?:index|home|main)(?:[\.\/](?:php|html?|\/?))?$", flags=re.MULTILINE)
test_str = ("http://bouquet-delivery.ru/index.php\n"
"http://bouquet-delivery.ru/home\n"
"http://bouquet-delivery.ru/home/\n"
"http://www.bouquet-delivery.ru/\n"
"http://www.bouquet-delivery.ru/index.php\n"
"http://www.bouquet-delivery.ru/index.html\n"
"http://www.bouquet-delivery.ru/index.htm\n"
"http://www.bouquet-delivery.ru/index/\n"
"http://www.bouquet-delivery.ru/home\n"
"http://www.bouquet-delivery.ru/home/\n"
"http://www.bouquet-delivery.ru/home.php\n"
"http://www.bouquet-delivery.ru/home.html\n"
"http://www.bouquet-delivery.ru/home.htm\n"
"http://www.bouquet-delivery.ru/main\n"
"http://www.bouquet-delivery.ru/main/\n"
"http://www.bouquet-delivery.ru/main.php\n"
"http://www.bouquet-delivery.ru/main.html\n"
"http://www.bouquet-delivery.ru/main.htm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")