package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:index|home|main)(?:[\.\/](?:php|html?|\/?))?$`)
var str = `http://bouquet-delivery.ru/index.php
http://bouquet-delivery.ru/home
http://bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/
http://www.bouquet-delivery.ru/index.php
http://www.bouquet-delivery.ru/index.html
http://www.bouquet-delivery.ru/index.htm
http://www.bouquet-delivery.ru/index/
http://www.bouquet-delivery.ru/home
http://www.bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/home.php
http://www.bouquet-delivery.ru/home.html
http://www.bouquet-delivery.ru/home.htm
http://www.bouquet-delivery.ru/main
http://www.bouquet-delivery.ru/main/
http://www.bouquet-delivery.ru/main.php
http://www.bouquet-delivery.ru/main.html
http://www.bouquet-delivery.ru/main.htm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}