#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)select(?:.|\n)*?(?!join)(?:.|\n)*?select"
Local $sString = "select as T_D" & @CRLF & _
" *" & @CRLF & _
"into table" & @CRLF & _
"" & @CRLF & _
"join spread ll" & @CRLF & _
"select as gege * from 'gagaga'" & @CRLF & _
"join" & @CRLF & _
"select * from qoqo" & @CRLF & _
"join" & @CRLF & _
"select as GEGE" & @CRLF & _
" select * as this_is_needed_to_be_sel" & @CRLF & _
" " & @CRLF & _
"into table" & @CRLF & _
"" & @CRLF & _
"join" & @CRLF & _
"select *" & @CRLF & _
"into table"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")