re = /select(?:.|\n)*?(?!join)(?:.|\n)*?select/m
str = 'select as T_D
*
into table
join spread ll
select as gege * from \'gagaga\'
join
select * from qoqo
join
select as GEGE
select * as this_is_needed_to_be_sel
into table
join
select *
into table'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end