using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"select(?:.|\n)*?(?!join)(?:.|\n)*?select";
string input = @"select as T_D
*
into table
join spread ll
select as gege * from 'gagaga'
join
select * from qoqo
join
select as GEGE
select * as this_is_needed_to_be_sel
into table
join
select *
into table";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}