const regex = /select(?:.|\n)*?(?!join)(?:.|\n)*?select/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('select(?:.|\\n)*?(?!join)(?:.|\\n)*?select', 'gm')
const str = `select as T_D
*
into table
join spread ll
select as gege * from 'gagaga'
join
select * from qoqo
join
select as GEGE
select * as this_is_needed_to_be_sel
into table
join
select *
into table`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}