import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "select(?:.|\\n)*?(?!join)(?:.|\\n)*?select";
final String string = "select as T_D\n"
+ " *\n"
+ "into table\n\n"
+ "join spread ll\n"
+ "select as gege * from 'gagaga'\n"
+ "join\n"
+ "select * from qoqo\n"
+ "join\n"
+ "select as GEGE\n"
+ " select * as this_is_needed_to_be_sel\n"
+ " \n"
+ "into table\n\n"
+ "join\n"
+ "select *\n"
+ "into table";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}