use strict;
my $str = 'select as T_D
*
into table
join spread ll
select as gege * from \'gagaga\'
join
select * from qoqo
join
select as GEGE
select * as this_is_needed_to_be_sel
into table
join
select *
into table';
my $regex = qr/select(?:.|\n)*?(?!join)(?:.|\n)*?select/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}