# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)/- $1\n/gm;t' <<< "PENNER,JANET E TR-50% & PENNER,MICHAEL G TR - 50% & SOURCE LLC & LARRY & FREDDY INC"