import re
regex = re.compile(r"(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)", flags=re.MULTILINE)
test_str = "PENNER,JANET E TR-50% & PENNER,MICHAEL G TR - 50% & SOURCE LLC & LARRY & FREDDY INC"
subst = "- $1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)