const regex = /(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)', 'gm')
const str = `PENNER,JANET E TR-50% & PENNER,MICHAEL G TR - 50% & SOURCE LLC & LARRY & FREDDY INC`;
const subst = `- $1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);