re = /(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)/m
str = 'PENNER,JANET E TR-50% & PENNER,MICHAEL G TR - 50% & SOURCE LLC & LARRY & FREDDY INC'
subst = '- $1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result