$re = '/(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)/m';
$str = 'PENNER,JANET E TR-50% & PENNER,MICHAEL G TR - 50% & SOURCE LLC & LARRY & FREDDY INC';
$subst = "- $1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;