#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(id=").+style="(.+)"
Local $sString = "id="**02_item2_02" duration="29" style="**joe"" & @CRLF & _
"id="02_item3_01" duration="35.5" style="joseph""
Local $sSubst = "$1$2 blah blah blah! text from the script"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)