# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(id=\").+style=\"(.+)"
test_str = ("id=\"**02_item2_02\" duration=\"29\" style=\"**joe\"\n"
"id=\"02_item3_01\" duration=\"35.5\" style=\"joseph\"")
subst = "$1$2 blah blah blah! text from the script"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.