using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(id="").+style=""(.+)";
string substitution = @"$1$2 blah blah blah! text from the script";
string input = @"id=""**02_item2_02"" duration=""29"" style=""**joe""
id=""02_item3_01"" duration=""35.5"" style=""joseph""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}