import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(id=\").+style=\"(.+)";
final String string = "id=\"**02_item2_02\" duration=\"29\" style=\"**joe\"\n"
+ "id=\"02_item3_01\" duration=\"35.5\" style=\"joseph\"";
final String subst = "$1$2 blah blah blah! text from the script";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}