re = /(id=").+style="(.+)/m
str = 'id="**02_item2_02" duration="29" style="**joe"
id="02_item3_01" duration="35.5" style="joseph"'
subst = '$1$2 blah blah blah! text from the script'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result