package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(id=").+style="(.+)`)
var str = `id="**02_item2_02" duration="29" style="**joe"
id="02_item3_01" duration="35.5" style="joseph"`
var substitution = "$1$2 blah blah blah! text from the script"
fmt.Println(re.ReplaceAllString(str, substitution))
}