#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^test(?:\/\d+)+$"
Local $sString = "test/1/5" & @CRLF & _
"test/1/2/5" & @CRLF & _
"test/1/2/3/5" & @CRLF & _
"test/1/2/3/4/5" & @CRLF & _
"test/1,2/5" & @CRLF & _
"test/1/2/5aaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")