$re = '/^test(?:\/\d+)+$/m';
$str = 'test/1/5
test/1/2/5
test/1/2/3/5
test/1/2/3/4/5
test/1,2/5
test/1/2/5aaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);