re = /^test(?:\/\d+)+$/m
str = 'test/1/5
test/1/2/5
test/1/2/3/5
test/1/2/3/4/5
test/1,2/5
test/1/2/5aaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end