import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^test(?:\\/\\d+)+$";
final String string = "test/1/5\n"
+ "test/1/2/5\n"
+ "test/1/2/3/5\n"
+ "test/1/2/3/4/5\n"
+ "test/1,2/5\n"
+ "test/1/2/5aaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}