// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^test(?:\/\d+)+$").unwrap();
let string = "test/1/5
test/1/2/5
test/1/2/3/5
test/1/2/3/4/5
test/1,2/5
test/1/2/5aaa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}