using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-z]{2}).*?(\d\d\W\d\d\W\d{2,4})\s*(.*)";
string input = @"SI12.08.2020 invoice already posted - status is incorrect - ticket at JIRA started 21.08.20
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}