re = /([A-z]{2}).*?(\d\d\W\d\d\W\d{2,4})\s*(.*)/m
str = 'SI12.08.2020 invoice already posted - status is incorrect - ticket at JIRA started 21.08.20
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end