use strict;
my $str = 'SI12.08.2020 invoice already posted - status is incorrect - ticket at JIRA started 21.08.20
';
my $regex = qr`([A-z]{2}).*?(\d\d\W\d\d\W\d{2,4})\s*(.*)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}