package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-z]{2}).*?(\d\d\W\d\d\W\d{2,4})\s*(.*)`)
var str = `SI12.08.2020 invoice already posted - status is incorrect - ticket at JIRA started 21.08.20
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}