import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-z]{2}).*?(\\d\\d\\W\\d\\d\\W\\d{2,4})\\s*(.*)";
final String string = "SI12.08.2020 invoice already posted - status is incorrect - ticket at JIRA started 21.08.20\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}