const regex = new RegExp('([A-z]{2}).*?(\\d\\d\\W\\d\\d\\W\\d{2,4})\\s*(.*)', 'gm')
const str = `SI12.08.2020 invoice already posted - status is incorrect - ticket at JIRA started 21.08.20
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}