package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\((Les|La|Le)\)`)
var str = `100 mots de la Chine (Les)
Gloire de mon père (La)
Temps des secrets (Le)`
var substitution = "$2 $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}