re = /(.*)\((Les|La|Le)\)/m
str = '100 mots de la Chine (Les)
Gloire de mon père (La)
Temps des secrets (Le)'
subst = '$2 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result