import re
regex = re.compile(r"(.*)\((Les|La|Le)\)", flags=re.MULTILINE)
test_str = ("100 mots de la Chine (Les)\n"
"Gloire de mon père (La)\n"
"Temps des secrets (Le)")
subst = "$2 $1"
result = regex.sub(subst, test_str)
if result:
print(result)