const regex = /(.*)\((Les|La|Le)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\((Les|La|Le)\\)', 'gm')
const str = `100 mots de la Chine (Les)
Gloire de mon père (La)
Temps des secrets (Le)`;
const subst = `$2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);