// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\((Les|La|Le)\)").unwrap();
let string = "100 mots de la Chine (Les)
Gloire de mon père (La)
Temps des secrets (Le)";
let substitution = "$2 $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}