$re = '/(.*)\((Les|La|Le)\)/m';
$str = '100 mots de la Chine (Les)
Gloire de mon père (La)
Temps des secrets (Le)';
$subst = "$2 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;