using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\W_])int(?![^\W_])";
string input = @"int # match
_int_ # match
__int__ # match
some_int # match
integration # doesn't match
mint # doesn't match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}