$re = '/(?<![^\W_])int(?![^\W_])/m';
$str = 'int # match
_int_ # match
__int__ # match
some_int # match
integration # doesn\'t match
mint # doesn\'t match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);