const regex = new RegExp('(?<![^\\W_])int(?![^\\W_])', 'gm')
const str = `int # match
_int_ # match
__int__ # match
some_int # match
integration # doesn't match
mint # doesn't match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}