import re
regex = re.compile(r"(?<![^\W_])int(?![^\W_])", flags=re.MULTILINE)
test_str = ("int # match\n"
"_int_ # match\n"
"__int__ # match\n"
"some_int # match\n"
"integration # doesn't match\n"
"mint # doesn't match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")