re = /(?<![^\W_])int(?![^\W_])/m
str = 'int # match
_int_ # match
__int__ # match
some_int # match
integration # doesn\'t match
mint # doesn\'t match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end