using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[json]:#.\(([^*]*)\)";
string substitution = @"";
string input = @"[json]:# (
[
{""jira"": ""proj-4753""},
{""creation"": ""2021-09-25""}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{""sensitivity"": ""internal""}
]
)
More data
[json]:# (
[
{""uid"": ""abc002334""}
]
)
and this";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}