// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[json]:#.\(([^*]*)\)").unwrap();
let string = "[json]:# (
[
{\"jira\": \"proj-4753\"},
{\"creation\": \"2021-09-25\"}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{\"sensitivity\": \"internal\"}
]
)
More data
[json]:# (
[
{\"uid\": \"abc002334\"}
]
)
and this";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}