use strict;
my $str = '[json]:# (
[
{"jira": "proj-4753"},
{"creation": "2021-09-25"}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{"sensitivity": "internal"}
]
)
More data
[json]:# (
[
{"uid": "abc002334"}
]
)
and this';
my $regex = qr/\[json]:#.\(([^*]*)\)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";