# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[json]:#.\(([^*]*)\)"
test_str = ("[json]:# (\n"
"[\n"
" {\"jira\": \"proj-4753\"},\n"
" {\"creation\": \"2021-09-25\"}\n"
"]\n"
")\n\n"
"# Title\n\n"
"## 1. Conclusion\n"
"Jada, jada\n\n"
"## 2. Recomendation\n"
"blah, blah\n\n"
"[json]:# (\n"
"[\n"
" {\"sensitivity\": \"internal\"}\n"
"]\n"
")\n\n"
"More data\n\n"
"[json]:# (\n"
"[\n"
" {\"uid\": \"abc002334\"}\n"
"]\n"
")\n"
"and this")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.