#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\$\n^\s+"
Local $sString = "add add-default-route=yes comment="WAN ROSTELECOM" disabled=no interface=\" & @CRLF & _
" ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\" & @CRLF & _
" 313131231 use-peer-dns=yes user=21412431241"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")