package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\$\n^\s+`)
var str = `add add-default-route=yes comment="WAN ROSTELECOM" disabled=no interface=\
ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\
313131231 use-peer-dns=yes user=21412431241`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}