// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\$\n^\s+").unwrap();
let string = "add add-default-route=yes comment=\"WAN ROSTELECOM\" disabled=no interface=\\
ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\\
313131231 use-peer-dns=yes user=21412431241";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}