import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\$\\n^\\s+";
final String string = "add add-default-route=yes comment=\"WAN ROSTELECOM\" disabled=no interface=\\\n"
+ " ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\\\n"
+ " 313131231 use-peer-dns=yes user=21412431241";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}