import re
regex = re.compile(r"\\$\n^\s+", flags=re.MULTILINE)
test_str = ("add add-default-route=yes comment=\"WAN ROSTELECOM\" disabled=no interface=\\\n"
" ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\\\n"
" 313131231 use-peer-dns=yes user=21412431241")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")